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Google Map

The Google Map component is a customizable, interactive Google Map. It includes a repeater that can
render a given symbol once for each row of data in a table. Each instance of the symbol appears at the
latitude and longitude specified in the table and can have other dynamic properties.

For a detailed reference of properties that affect Google Maps components, see Common Properties and
Google Map Properties.

Important

To use the Google Maps API, include a JavaScript dataflow block in the dataflow for the map
component.

A Google Map component in DGLux5. This map uses a repeater and custom styling.

https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:repeaters:home
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:components:symbols:home
https://wiki.dglogik.com/dglux5_wiki:dataflow:working_with_tables:home
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:property_inspector:allcomponents:home
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:property_inspector:map:home
https://wiki.dglogik.com/dglux5_wiki:dataflow:dataflow_blocks_reference:browser_api:javascript#google_maps_api_example
https://wiki.dglogik.com/dglux5_wiki:dataflow:home
https://wiki.dglogik.com/_media/dglux5_wiki:widgets_and_property_inspector:dglux5_components_googlemap_0.png
https://snazzymaps.com
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Video Tutorial: Custom Google Maps Dashboards

More video tutorials are here.

Create a Google Map Component in DGLux5

To create a Google Map component with a repeater:

Right-click in the Outline or the Document window, and select Insert > Components > Google1.
Map.

Create a symbol to act as your map marker.2.

If you want instances of the symbol to have dynamic properties other than latitude and longitude,
create parameters for the symbol. Bind the parameters to the relevant properties. See Symbol.

Open the dataflow for the Google Map component.3.

The dataflow contains a table.

Load the latitude and longitude data that you want to use.4.

You can do this by deleting the existing table and loading a new one as discussed in Working with
Tables. Or, you can open the existing table and edit it manually.

If you are using a symbol with parameters, your table must include columns for the parameter
values.

In the Outline, select the map.5.
In the Property Inspector, under Repeater:6.

For Symbol, type the name of the symbol.1.
Bind the table containing your latitude and longitude data to the Data property.2.
For Latitude Field and Longitude Field, type the names of the table columns that contain3.
this data.

In the Outline, select the "renderer" node that is a child of the map.7.

In the Property Inspector, for each symbol parameter, either enter a value or bind a table column.8.

To bind a table column, open the table in dataflow and drag the column header to this field.

http://dglogik.com/videos
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:repeaters:home
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:outline
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:document_window
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:components:symbols:home
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:components:symbols:home
https://wiki.dglogik.com/dglux5_wiki:dataflow:home
https://wiki.dglogik.com/dglux5_wiki:dataflow:working_with_tables:home
https://wiki.dglogik.com/dglux5_wiki:dataflow:working_with_tables:home
https://wiki.dglogik.com/dglux5_wiki:dataflow:working_with_tables:home
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Use JSON Styles

You can find JSON for a selection of pre-made map styles here.

You can also create JSON for a custom style using this wizard.

To pass a JSON object for map style to DGLux5:

Copy the JSON code.1.
In the Outline or Document window, select the Google Map component.2.
In the Advanced properties, for the mapStyles property, click  Edit in Window.3.
Paste the JSON in the pop-up, and click OK.4.

Google Maps FAQ

This section provides answers to some common questions about creating Google Map components in
DGLux5.

For frequently asked questions about manipulating the tables that determine the placement of markers
by a map repeater, see Working with Tables.

Click to display/hide all elements

How do I show or hide satellite, road map, terrain, or traffic information?
To show or hide satellite, road map, or terrain data:

In the Outline or Document window, select the Google Map component.1.
In the Property Inspector, under Map, edit the Map Type property.2.

Roadmap shows the default, road map view.
Satellite shows Google Earth satellite images.
Hybrid shows a mixture of road map and satellite images.
Terrain shows a physical map based on terrain data.

To show or hide the Google Maps traffic layer:

In the Outline or Document window, select the map.1.
In the Property Inspector, under Map, edit the Traffic property.2.

How do I change the location and zoom level at which the map opens?
By default, the map opens on San Francisco, CA, with a zoom level of 10.

To manually change the location and zoom level of the map:

In the Outline or Document window, select the Google Map component.1.

https://snazzymaps.com/
http://googlemaps.github.io/js-samples/styledmaps/wizard/index.html
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:outline
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:document_window
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:advanced_panel
https://wiki.dglogik.com/dglux5_wiki:dataflow:working_with_tables:home
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:outline
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:document_window
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:properties_panel
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:outline
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:document_window
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In the Property Inspector, under Map, edit the Latitude, Longitude, and Zoom properties.2.

The maximum zoom level depends on available data for a location and is typically between 18 and
21.

How do I show or hide controls for the user?
You can enable the user to zoom in or out, and move left, down, right, or up using buttons.

To show or hide map controls:

In the Outline or Document window, select the map.1.
In the Property Inspector, under Map, edit the Map Controls property.2.

How do I include a dynamic callout as part of my repeater?
Your repeated map marker can include a callout. To create this effect, you create a callout symbol and
make some changes to the marker symbol and the table.

A map repeater with a dynamic callout. When the user mouses over the marker, the callout appears.

First, create a Google Map with a repeater as described above.

To add a mouse-over callout to the repeater:

Create a new symbol to be used as the callout.1.
For the callout symbol, create a parameter for each property that you want to be dynamic, and2.
bind them to the appropriate properties. See Symbol.
Edit the marker symbol:3.

In the Symbols panel, right-click the marker symbol and select Edit.1.
In the Outline, make sure the symbol node is selected.2.
In the Menu Bar, select Modify > Edit Properties, and create a parameter for each3.
dynamic property of the callout symbol that you defined in step 2. Make sure the data types
are the same.
Close the Symbol Parameters dialog, and click Apply in the symbol editing dialog to apply4.
changes and continue editing.
At the bottom of the Property Inspector, under Callout, select  Mouse-Over.5.
For the Symbol property, type the name of the callout symbol.6.

https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:properties_panel
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:outline
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:document_window
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:properties_panel
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:callouts:home
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:components:symbols:home
https://wiki.dglogik.com/_media/dglux5_wiki:widgets_and_property_inspector:dglux5_components_googlemap_1.png
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:components:symbols:home
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:callouts:home
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:components:symbols:home
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:symbols_panel
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:outline
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Click Apply in the symbol editing dialog.7.

The callout now appears when the user mouses over a marker. This happens in Preview
Mode but not Edit Mode.

Click OK in the symbol editing dialog to apply changes and exit the symbol editing mode.4.
In the map's dataflow, make sure that the table includes a column for each callout symbol5.
parameter. See Working with Tables.
Bind the table data to the renderer:6.

Open the dataflow table for the map component.1.
In the Outline, select the "renderer" node that is a child of the map.2.
Bind the relevant table column to the relevant parameter in the Property Inspector.3.

Bind the marker symbol parameters to its callout properties:7.
In the Symbols panel, right-click the marker symbol, and select Edit.1.
In the Menu Bar, select Modify > Edit Properties.2.
In the Outline, expand the symbol, and select the "callout" node that is a child of the symbol.3.
Bind the relevant symbol parameter to the relevant property in the Property Inspector.4.

How do I use the Google Maps API with DGLux5?
To use the Google Maps API, include a JavaScript block in the dataflow for the map component. See the
JavaScript block page for an example.

Google Map Properties

These properties affect the Google Map component.

For a guide to using the Google Map component, see Google Map.

Google Map components are also affected by Common Properties.

https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:edit_preview:home
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:edit_preview:home
https://wiki.dglogik.com/dglux5_wiki:dataflow:home
https://wiki.dglogik.com/dglux5_wiki:dataflow:working_with_tables:home
https://wiki.dglogik.com/dglux5_wiki:dataflow:working_with_tables:home
https://wiki.dglogik.com/dglux5_wiki:dataflow:home
https://wiki.dglogik.com/dglux5_wiki:dataflow:dataflow_blocks_reference:browser_api:javascript#google_maps_api_example
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:property_inspector:allcomponents:home


2022/02/09 14:26 6/12 Google Map

DGLogik - https://wiki.dglogik.com/

Google Map properties in the Property Inspector

Click to display/hide all elements

These properties affect the map:

API Key
Specifies the Google Maps API key to use.

You are responsible for the use of Google Maps and for compliance with Google's licensing. For details,
please see Google's Terms of Service for Google Maps and Google Earth.

https://wiki.dglogik.com/_media/dglux5_wiki:widgets_and_property_inspector:property_inspector:properties_google_map.png
https://developers.google.com/maps/terms#section_9_1
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The API Key property

Map Type
Defines the type of Google Map to be displayed in the component.

Roadmap
The default road map view.

Satellite
Google Earth satellite images.

Hybrid
A mixture of road map and satellite images.

Terrain
A physical map based on terrain data.

The Map Type property

Latitude

https://wiki.dglogik.com/_media/dglux5_wiki:widgets_and_property_inspector:property_inspector:properties_google_map_api_key.png
https://wiki.dglogik.com/_media/dglux5_wiki:widgets_and_property_inspector:property_inspector:properties_google_map_type.png
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Sets or returns the latitude at the center of the map component.

The Latitude property

Longitude
Sets or returns the longitude at the center of the map component.

The Longitude property

Zoom
Sets or returns the zoom level for the map. Zero is the lowest zoom level, in which the entire world can
be seen in one map. For each map type, valid zoom levels are from 0 to the maximum zoom level for
that location and map type. The maximum depends on available data and is typically between 18 and 21
for a given location and map type.

https://wiki.dglogik.com/_media/dglux5_wiki:widgets_and_property_inspector:property_inspector:properties_google_map_lat.png
https://wiki.dglogik.com/_media/dglux5_wiki:widgets_and_property_inspector:property_inspector:properties_google_map_long.png
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The Zoom property

Map Controls
Specifies whether to show map controls, allowing the user to manipulate the map. Controls allow the
user to zoom in or out, and move left, right, down, or up.

The Map Controls property

Traffic
Specifies whether to show the Google Maps Traffic Layer on the map.

https://wiki.dglogik.com/_media/dglux5_wiki:widgets_and_property_inspector:property_inspector:properties_google_map_zoom.png
https://wiki.dglogik.com/_media/dglux5_wiki:widgets_and_property_inspector:property_inspector:properties_google_map_controls.png
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The Traffic property

These properties affect the map repeater:

Symbol
Defines the symbol to be used as a location marker. If the symbol is in this project, enter the name of
the symbol. To use a symbol from another project in your library, enter the path to that symbol.

The Symbol property

Data
Defines the table from which latitude and longitude data for location markers can be determined. By
default, Google Map has a table case block that you can play with.

The Data property

https://wiki.dglogik.com/_media/dglux5_wiki:widgets_and_property_inspector:property_inspector:properties_google_map_traffic.png
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:repeaters:home
https://wiki.dglogik.com/_media/dglux5_wiki:widgets_and_property_inspector:property_inspector:properties_google_map_repeater_symbol.png
https://wiki.dglogik.com/_media/dglux5_wiki:widgets_and_property_inspector:property_inspector:properties_google_map_repeater_data.png
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To use the default table:

In the Outline, double-click the dataflow icon of your Google Map component.1.
Select the table case block in dataflow so you can see the properties.2.
Hover over the table button until a blue dot appears. Then, click the blue dot and drag it over to3.
the Data property.

|

Latitude Field, Longitude Field
Define the columns in your table that contain latitude and longitude data.

To use the latitude and longitude columns from the default table, enter latitude and
longitude.

The Latitude Field and Longitude Field properties

The following properties affect the map group. A map group is useful when you want to have multiple
repeaters, or other components, in your map, or when you want your markers to be placed at each set of
coordinates without being centered on the location.

https://wiki.dglogik.com/_media/dglux5_wiki:property_inspector:google_map_data.png
https://wiki.dglogik.com/_media/dglux5_wiki:widgets_and_property_inspector:property_inspector:properties_google_map_repeater_lat_long.png
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:repeaters:home
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Symbol
Defines the symbol to be used as a location marker in this map group. If the symbol is in this project,
enter the name of the symbol. To use a symbol from another project in your library, enter the path to
that symbol.
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