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Component and Widget Essentials

DGLux5 components are customizable, graphical building blocks for web applications. A widget is a
custom graphical element that comprises one or more DGLux5 widgets, components, shapes, or paths.
When you create a project in DGLux5, you add components and widgets to a page or set of pages. Then,
you customize the behavior and appearance of each object using properties, dataflow, and actions.
DGLux5 has four kinds of components: Components, Charts, Gauges, and Form Input.

When you add a widget to the widget palette, you can re-use it in different pages and projects. You can
load widgets from other projects using your lib directory.

Insert Components

You insert components, and some default widgets such as charts, using the Insert menu.

To insert a core component or default DGLux5 chart widget into your Document window:

In the Outline or the Document window, select the Stage or a group.1.

In the Main Menu, select Insert, and choose the component to add.2.

The component is inserted as a child of the selected Stage or group.

https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:property_inspector:home
https://wiki.dglogik.com/dglux5_wiki:dataflow:home
https://wiki.dglogik.com/dglux5_wiki:actions:home
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:components:home
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:charts:home
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:gauges:home
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:form_input:home
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:widget_palette
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:projects_and_files:project_directories
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:document_window
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:outline
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:document_window
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Inserting a Google Map component onto the Stage

https://wiki.dglogik.com/_media/dglux5_wiki:widgets_and_property_inspector:component_types:essentials:essentials_0.png


2022/02/08 09:15 3/10 Component and Widget Essentials

DGLogik - https://wiki.dglogik.com/

Inserting a text component into a group

You can also insert components by right-clicking the Stage or group.

Insert Widgets

You insert widgets using the widget palette.

These steps only work in Edit mode.

To insert a widget from the widget palette:

Expand the relevant category in the widget palette.1.

Drag the widget to the Document window.2.

When you drop the widget, it is inserted as a child of the Stage or the first available unlocked group
at your mouse location.

https://wiki.dglogik.com/_media/dglux5_wiki:widgets_and_property_inspector:component_types:essentials:essentials_2.png
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:widget_palette
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:edit_preview:home
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:widget_palette
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:document_window
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Inserting a widget onto the Stage by dropping it over an empty area in the Document window

Edit Components and Widgets

Edit a component or widget by selecting it and then using the Properties panel.

In general, changes that you make in the palette and lib directories affect widget palettes but do not
"trickle down" to instances of the widget. See Edit Widgets for more information.

Select Objects

You can select one or more children of the same group simultaneously. You cannot select children from

https://wiki.dglogik.com/_media/dglux5_wiki:widgets_and_property_inspector:component_types:essentials:essentials_3.png
https://wiki.dglogik.com/_media/dglux5_wiki:widgets_and_property_inspector:component_types:essentials:essentials_4.png
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:properties_panel
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:projects_and_files:project_directories
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:widget_palette
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:widget_palette#edit_widgets
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different groups simultaneously.

To select an object, you use one of the following:

The Outline lets you select objects from a list.
The  Select tool lets you select objects visually in the WYSIWYG Document window.
The  Path Selection tool lets you select paths within an object in the WYSIWYG Document
window. For example, this lets you select a single axis or series of a chart widget.

Use the Outline

To select objects using the Outline:

In the Outline, click the object.1.

You may have to click a toggle arrow to expand a group, or scroll up or down in the panel to locate
the object.

Shift + click to add another object, and all of the objects in between, to the selection.2.

You can also Ctrl + click or Command + click to change whether an item is part of the selection.

Horizontal Layout, Breadcrumbs and Header groups have been selected

https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:outline
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:document_window
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:outline
https://wiki.dglogik.com/_media/dglux5_wiki:widgets_and_property_inspector:widget_essentials:dglux_outline_selection.png
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Use the Select Tool

These steps work only in Edit mode.

To select items using the Select tool:

In the Tools panel, click the  Select tool.1.
Either click an object, or drag to select multiple objects.2.
Shift + click to change whether an item is part of the selection.3.

https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:edit_preview:home
https://wiki.dglogik.com/_media/dglux5_wiki:widgets_and_property_inspector:widget_essentials:dglux_selection_marquee_1.png


2022/02/08 09:15 7/10 Component and Widget Essentials

DGLogik - https://wiki.dglogik.com/

Dragging over objects to select them

Use the Path Selection Tool

These steps only work in Edit mode.

To use the Path Selection tool:

In the Tools panel, click the  Path Selection tool.1.
In the Document window, do one of the following:2.

Click individual anchor points or path segments to select them.
Click a portion of a path that is not an anchor point to select the entire path.

Tip

To select an object that lies behind another object, click multiple times without moving the
mouse. Selection iterates through the objects at the cursor position, beginning with the
topmost object.

https://wiki.dglogik.com/_media/dglux5_wiki:widgets_and_property_inspector:widget_essentials:dglux_selection_marquee_2.png
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:edit_preview:home
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:document_window
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Group and Ungroup Objects

You can group widgets and components. Groups are useful for responsive layouts, symbols, repeaters,
and widgets that comprise multiple components.

When you group objects, the stacking order of your page might change. A group is arranged immediately
behind the frontmost object in the group.

A group can be a child of another group.

Group Objects

Select the widgets and components to be grouped.1.
Do one of the following:2.

In the Quick Access panel, click  Group.
In the Main Menu, choose Modify > Group.
Right-click on one of the selected objects, and select Group.
In the Outline, insert a Group component, and then drag objects into the group.

Ungroup Objects

Select the group.1.
Do one of the following:2.

In the Quick Access panel, click  Ungroup
In the Main Menu, choose Modify > Ungroup
In the Document window or Outline, right-click on one of the selected objects, and select
Ungroup.

Remove a Child from a Group

In the Outline, select the child, and drag it out of the group.

Move Objects

You can move objects by dragging them, by using arrow keys on the keyboard, or by entering precise
values in the Property Inspector.

Move Objects by Dragging

https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:components:group:home
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:components:symbols:home
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:components:symbols:home#about_repeaters
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:widget_palette
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:tools_panel
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:outline
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:tools_panel
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:document_window
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:outline
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:outline
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:properties_panel
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These steps only work in Edit mode. Snapping can help you position objects.

To drag objects:

Select one or more objects.1.
In the Document window, drag the object to a new location.2.

Move Objects Using the Arrow Keys

These steps only work in Edit mode. Snapping can help you position objects.

To move objects using the arrow keys:

Select one or more widgets or objects.1.

Press the arrow keys to move the objects.2.

The object moves one pixel for each keystroke. Hold Shift to move the object five pixels per
keystroke.

Specify Position Properties in the Property Inspector

See also: Position and Size Properties

To specify position properties:

Select one or more widgets or objects.1.

In the Property Inspector, under Position and Size, specify the appropriate position properties.2.
For example, you could set the Top and Left properties to pixel values, or you could set the
Horizontal Center and Vertical Center properties to pixel values.

Top and left position coordinates enabled and set

Previous: Components and Widgets

Next: Shapes and Paths

https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:edit_preview:home
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:grid_and_snapping:home
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https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:edit_preview:home
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https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:property_inspector:allcomponents:position_size
https://wiki.dglogik.com/dglux5_wiki:workspace_and_workflow:panels_and_menus:properties_panel
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https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:home
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:shapes_paths:home


2022/02/08 09:15 10/10 Component and Widget Essentials

DGLogik - https://wiki.dglogik.com/

From:
https://wiki.dglogik.com/ - DGLogik

Permanent link:
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:essentials:home

Last update: 2021/09/20 14:51

https://wiki.dglogik.com/
https://wiki.dglogik.com/dglux5_wiki:widgets_and_property_inspector:essentials:home

	Component and Widget Essentials
	Insert Components
	Insert Widgets
	Edit Components and Widgets
	Select Objects
	Use the Outline
	Use the Select Tool
	Use the Path Selection Tool
	Tip


	Group and Ungroup Objects
	Group Objects
	Ungroup Objects
	Remove a Child from a Group

	Move Objects
	Move Objects by Dragging
	Move Objects Using the Arrow Keys
	Specify Position Properties in the Property Inspector



