Keyboard Shortcuts

A keyboard shortcut is a set of one or more keys that invoke a DG Solution Builder operation when pressed by the user. You can use these to expedite common operations.


These lists provide shortcuts to items in the Main Menu.

File Menu

This list provides shortcuts to items in the File menu.

Result Windows Mac OS
New File Shift + N Shift + N
Open File Ctrl + O Cmd + O
Save File Ctrl + S Cmd + S
Save File As Ctrl + Alt + S Cmd + Opt + S
Import DG5 Ctrl + 7 Ctrl + 7

Project Menu

This list provides shortcuts to items in the Project menu.

Result Windows Mac OS
Import Project Ctrl + I Ctrl + 8
Export Current Project Ctrl + E While no items on the page are selected, press Ctrl + 9 or Cmd + 9.

Edit Menu

This list provides shortcuts to items in the Edit menu.

Result Windows Mac OS
Undo Ctrl + Z Cmd + Z
Redo Ctrl + Y Cmd + Y
Cut Ctrl + X Cmd + X
Copy Ctrl + C Cmd + C
Paste Ctrl + V Cmd + V
Duplicate Ctrl + D Cmd + D

View Menu

This list provides shortcuts to items in the View menu.

Result Windows Mac OS
Snap to Component Ctrl + Period (.) Cmd + Period (.)

Tools Panel

This list provides shortcuts for the Tools panel. These shortcuts do not work when you are editing text.

Pressing a key has the same effect as clicking a tool once. To select a drawing tool in multiple drawing mode, use the keyboard shortcut twice.

Result Windows Mac OS
Selection tool S S
Path selection tool Ctrl + Shift + P Cmd + Shift + P or Ctrl + Shift + P
Transform tool T T
Rectangle tool R R
Ellipse tool E E
Path tool Ctrl + P Ctrl + P
Line tool L L
Polyline tool W W

Quick Access Panel

This list provides shortcuts to commands in the Quick Access panel.

Result Windows Mac OS
Group elements Ctrl + G Cmd + G or Ctrl + G
Ungroup elements Ctrl + U Cmd + U or Ctrl + U
Full size Ctrl + 9 Ctrl + 9 or Cmd + 9
Undo Ctrl + Z Cmd + Z or Ctrl + Z
Redo Ctrl + Y Cmd + Y or Ctrl + Y

Selection

This list provides shortcuts to selection commands.

Result Windows Mac OS
Select all Ctrl + A Cmd + A or Ctrl + A
Clear current selection Ctrl + Alt + A Ctrl + Opt + A
Add items to the current selection, or remove items from the current selection With the Selection tool, Ctrl + click items With the Selection tool, Shift + click items

Panel Management

These shortcuts relate to managing panels in the workspace.


Application Mode

This shortcut relates to the current Application mode.

  • Hold P to temporarily change to Preview mode. Release P to return to Edit mode.